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1 PROCEDURES 
 
1.1 Introduction 

Most users will be comfortable with contacting their IT Helpdesk for completing the instructions 
below.  However, if you have Admin rights on your workstation, and are comfortable with making 
configuration changes to it, you may follow these directions yourself. 
 

1.2 Installation of ActiveX Control 
 
WINDOWS XP 

1. Log onto the workstation to be configured using an ID/Password that can perform administrative 
functions on that workstation (e.g. Install software, add Active-X controls). Note that 
administrative access is only required for initial workstation configuration, not ongoing operation of 
the PARS II application. 

2. Check hardware, software and network requirements as identified in section 2 below.  Less than 
minimum requirements are unsupported and can mean unpredictable results. 

3. Using Microsoft Internet Explorer 8, open this link: 
https://pars2.doe.gov/PARS2/SSSTemp/wfSSSXlsView.aspx?RPTID=1000000 

4. There will be the thin yellow bar at the top of the application window:”This website wants to install 
the following add-on” ‘Dekker, Ltd.’ From ‘Dekker, Ltd.’. If you trust the website and the add-on, 
and want to install it, click here”.  Install the Add-On, “…for all users on This Computer”.  Note: 
This website has been Certified and Accredited by DOE, and is safe to install controls deployed from 
this site. 

5. You may receive one or more “Internet Explorer Security Warning” popup windows advising that 
“The software you are installing has not passed Windows Logo testing to verify its compatibility 
with Windows XP.”.  Click on “Continue Anyway” every time this popup appears. 

6. The required Active-X control from Dekker will have been installed and the workstation should now 
display a confirmation Excel report, possibly with an Excel macro security warning. 

7. Close Excel, click [no] to the question about saving the spreadsheet. 
8. Close all Internet Explorer 8 windows which have opened during the install process. 
9. Refer to section 1.3 below for additional instructions on Excel macro security. 

 
WINDOWS7 (32-bit and 64-bit) 

1. Log onto the workstation to be configured using an ID/Password that can perform administrative 
functions on that workstation (e.g. Install software, add Active-X controls). Note that 
administrative access is only required for initial workstation configuration, not ongoing operation of 
the PARS II application. Depending on local security group policies, it may be required that the OS 
account of the end user who will run PARS2 reports will need to have its privileges temporarily 
elevated to administrator for the ActiveX installation.  This varies from site to site; please check 
with your site IT support personnel for more information.  

2. Check hardware, software and network requirements as identified in section 2 below.  Less than 
minimum requirements are unsupported and can result in unpredictable results. 

3. Windows7 64-bit users must use the 32-bit version of Internet Explorer 8 (this is the shortcut not 
labeled 64-bit). 

4. Internet explorer must be started by right-clicking on the Internet Explorer icon and choosing “Run 
as Administrator” 

5. Click “Yes” when prompted by a window that starts “Do you want to allow the following Program to 
make changes to this computer?” 

6. Using Microsoft Internet Explorer 8, open this link: 
https://pars2.doe.gov/PARS2/SSSTemp/wfSSSXlsView.aspx?RPTID=1000000 

7. A yellow bar at the top of the browser will display this message - “To help protect your security, 
Internet Explorer has restricted this site from showing certain content. Click here for options” 

8. A box in the browser window will display - “Click here to install the following ActiveX control: 
‘Dekker, Ltd.’ From ‘Dekker, Ltd.’…” 

https://pars2.doe.gov/PARS2/SSSTemp/wfSSSXlsView.aspx?RPTID=1000000
https://pars2.doe.gov/PARS2/SSSTemp/wfSSSXlsView.aspx?RPTID=1000000


Configuring Workstations for use with the PARS II System 
6/27/2012 

 

Page 2 of 5 

9. Right-click on the second message and select “Install This Add-on for All Users on This Computer…” 
10. A box pops up with a message that begins “Do you want to install this software?”  Click on “Install” 
11. You should see Microsoft Office Excel open a new spreadsheet confirming that you have 

successfully installed the Dekker, Ltd. ActiveX Control. 
 

1.3 Set MS Office Macro Security to Allow Digitally Signed Content from 
Application Vendor 

 
Microsoft Office Excel 2010 (32-bit) 

1. Start Microsoft Office Excel 2010. 
2. Click on the “File” tab on the upper left. 
3. Click on the “Options” menu on the lower left. 
4. On the left Navigation Bar, click on “Trust Center”. 
5. On the right, click on “Trust Center Settings”. 
6. On the left Navigation Bar, click on “Macro Settings”. 
7. Click on the Radio Button “Disable all macros except digitally signed macros”. 
8. Click on [OK]. 
9. Exit Excel. 
10. After Installing the Dekker, Ltd. ActiveX control, log in to PARS II and run the “Project Overview”. 
11. The report will appear with a yellow warning below the ribbon “Security Warning Some active 

content has been disabled.  Click for more details” 
12. DO NOT Click on the “Enable Content” button 
13. Click on the “File” tab, upper left, above the ribbon 
14. Locate the “Security Warning” section in the Info menu which says “Active content might contain 

certain viruses and other security hazards. The following content has been disabled – Macros.  You 
should enable content only if you trust the contents of the file” 

15. Click on the arrow under “Enable Content”. 
16. Select “Advanced Options”. 
17. “Security Alert – Macros & ActiveX” window appears 
18. Click on the Radio Button “Trust All documents from this publisher”. 
19. Click on [OK]. 
20. Verify that the report is now displaying correctly without a security warning bar. 

 
Microsoft Office Excel 2007 

1. Start Microsoft Office Excel 2007. 
2. Click on the MS Office icon in the upper left-hand corner of the Excel application window. 
3. Click on the [Excel Options] button at the bottom. 
4. On the left Navigation Bar, click on “Trust Center”. 
5. On the right, click on “Trust Center Settings”. 
6. On the left Navigation Bar, click on “Macro Settings”. 
7. Click on the Radio Button “Disable all macros except digitally signed macros”. 
8. Click on [OK]. 
9. Exit Excel. 
10. Logon to PARS II 
11. Click on “All Reports“, then “SSS Reports”. 
12. Click on the “+” sign to expand the PARS Reports folder. 
13. Click on “2A Project Summary by Program”. 
14. Click View and wait for Excel to open – ignore data values within sheet. 
15. If there is a Security Warning bar directly under the Office tool bar, click the Options button 
16. A "Security Alert - Macros & ActiveX" screen will open, requesting a decision on whether to trust 

content from the application vendor. 
17. Select "Trust all documents from this publisher" 
18. Click OK. 
19. Close Excel. 
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20. View the report again and verify that the report is displaying correctly without a security warning 
bar. 

 
Microsoft Office Excel 2003 

1. Start Microsoft Office Excel 2003. 
2. Click on the Tools menu item. 
3. Select Macro. 
4. Click on the Security tab. 
5. Click on Security Level and select Medium. 
6. Click OK to close the Security screen. 
7. Exit Excel. 
8. Logon to PARS II. 
9. Click on “All Reports”, then “SSS Reports” 
10. Click on the “+” to expand the PARS Reports folder. 
11. Click on “2A Project Summary by Program”. 
12. Click View and wait for Excel to open – ignore data values within the sheet. 
13. If there is a Security Warning bar directly under the Office tool bar, click the Options button. 
14. A "Security Alert - Macros & ActiveX" screen will open. 
15. Select "Trust all documents from this publisher". 
16. Click OK. 
17. Close Excel. 
18. View the report again and verify that the report is displaying correctly without a security warning 

bar. 
 

2 HARDWARE, SOFTWARE AND NETWORK REQUIREMENTS 
 

 Minimum 1280 X 1024 Display (Monitor and Graphics card) 
 2Gb memory 
 2 CPU cores at 2.5 GHz or 1 CPU core at 3+ GHz 
 MS Windows XP or Windows7 (32- or 64-bit versions) any edition (e.g. Home, Professional, 

Ultimate) 
 MS Internet Explorer 7, 8 or 9 (Native Mode or Compatibility Mode).  Windows7 64-bit users must 

use the 32-bit version of Internet Explorer 8. 
 Microsoft Excel 32-bit for 2003, 2007 and 2010 are supported spreadsheet applications 
 Network connectivity to https://pars2training.doe.gov/ and https://pars2.doe.gov/ for web and 

transfer of Excel spreadsheets (with embedded macros). 
 

2.1 Internet Explorer Configuration 
PARS II is configured to allow users to access the application using any of the following browser 
versions/modes: 

• Internet Explorer 7 (native mode);  
• Internet Explorer 8 (native mode); or  
• Internet Explorer 9 (native mode or compatibility mode).   

 
Workstations (using Internet Explorer 7 or 8) which are properly configured and already working with 
PARS II require no further action. All other workstations (including those using Internet Explorer 9) 
need to be configured in accordance with Sections 1.2 and 1.3 of this document. 

 
At this time, the following browsers/modes remain unsupported: Google Chrome; Firefox; Internet   
Explorer 7 (compatibility mode); Internet Explorer 8 (compatibility mode); and any other 
browser/mode not listed above.   

 

https://pars2training.doe.gov/
https://pars2.doe.gov/
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3 VERIFYING PARS II ACTIVEX CONTROL VERSION 
 

1. Open Windows Explorer  
a. On the Windows XP Desktop: Click START > PROGRAMS > ACCESSORIES > WINDOWS 

EXPLORER 
b. On the Windows 7 Desktop: Click START > ALL PROGRAMS > ACCESSORIES > WINDOWS 

EXPLORER 
2. Go to C:\WINDOWS\DOWNLOADED PROGRAM FILES 

a. Both Windows XP and 7: In Windows Explorer, double-click on "My Computer", then the 
"C:" drive, then the "WINDOWS" directory, then the "Downloaded Program Files" directory 

3. Check the version of the ActiveX Control 
a. In Windows XP: Right-click on DkrSSSWebControl8.DkrSSSWebControl, select “Properties”, 

click on "Versions" Tab, verify that "Version" is “8,2,0,1” 
b. In Windows 7: Right-click on DkrSSSWebControl.ocx, select “Properties”, click on "Details" 

Tab, verify that "File Version" is “8.2.0.1” 
 

4 ADDITIONAL HELP 
 
4.1 PARS II Helpdesk 
 
• By Telephone  

o DC Metro Area – 301-903-2500 
o Nationally – 1-866-834-6246 
o Once connected, select option 4, then option 5 

• By Email 
o i-Manage.eas@hq.doe.gov 
 

4.2 PARS II Website 
 
• The PARS II website is a good source of help and information about PARS II 
• http://www.management.energy.gov/online_resources/pars2.htm 

mailto:i-Manage.eas@hq.doe.gov
http://www.management.energy.gov/online_resources/pars2.htm
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Change Control Page 
 
The change control page is used to record information about the changes (i.e., additions, modifications, 
deletions) that have been made to this document. 
 
Revision 

Date 
Section 
 & Title 

Page 
Numbers 

Summary Of Changes Author 

7/26/2010 All All  Initial Document B. Schwalm 

7/27/2010 Document title, 
page 

numbering, 
Sections 2.1, 
2.2 and 3.1  

All Format and content changes B. Schwalm 

8/3/2010 1.3 Set MS 
Excel Macro 
Security to 
Allow Digitally 
Signed Content 
from Dekker, 
Ltd 

2 Added Excel 2003 instructions B. Schwalm 

8/4/2010 All All Various format and spelling changes.  
Removed all references to “Dekker, Ltd.” 

B. Schwalm 

9/14/2010 1.2 1 and 2 Added Windows 7 ActiveX instructions B. Schwalm 

9/14/2010 1.3 3 Revised MS Excel 2003 instructions B. Schwalm 

6/16/2011 3 3 forward Added section for verifying ActiveX 
Control Version 

B. Schwalm 

6/6/2012 1.3 
 
2 

2 
 
3 

Revised Microsoft Office Excel 2010 (32-
bit) Version Requirements 
Revised Hardware, Software and Network 
Requirements 

M. Cree 

6/22/2012 2 
 

2.1 

3 
 

3 and 4 

Revised Hardware, Software and Network 
Requirements 
Added section for enabling Internet 
Explorer 9 in Compatibility Mode 

M. Cree 

6/27/2012 2 
 

2.1 

3 
 
3 

Revised Hardware, Software and Network 
Requirements 
Removed section for enabling Internet 
Explorer 9 in Compatibility Mode 
Added section for Internet Explorer 
Configuration 

M. Cree 
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