You are here

V-207: Wireshark Multiple Denial of Service Vulnerabilities

July 31, 2013 - 1:59am

Addthis

PROBLEM:
Multiple vulnerabilities have been reported in Wireshark, which can be exploited by malicious people to cause a DoS (Denial of Service) and potentially compromise a vulnerable system.

PLATFORM:
Wireshark 1.x

ABSTRACT:
Successful exploitation of this vulnerability may allow execution of arbitrary code.

REFERENCE LINKS:
CVE-2013-4083
CVE-2013-4923
Secunia Advisory SA54296

IMPACT ASSESSMENT:
Medium

DISCUSSION:
The dissect_pft function in epan/dissectors/packet-dcp-etsi.c in the DCP ETSI dissector in Wireshark 1.6.x before 1.6.16, 1.8.x before 1.8.8, and 1.10.0 does not validate a certain fragment length value, which allows remote attackers to cause a denial of service (application crash) via a crafted packet.

IMPACT:
DoS, System access

SOLUTION:
Update to version 1.10.1, 1.8.9, or later. 

Addthis