You are here

T-569: Adobe Flash SWF File Processing Memory Corruption Remote Code Execution Vulnerability

March 3, 2011 - 3:05pm

Addthis

PROBLEM:

Adobe Flash Player contains a vulnerability that could allow an unauthenticated, remote attacker to execute arbitrary code on a targeted system.

PLATFORM:

Adobe Flash Player versions 10.1.102.64 and prior

ABSTRACT:

Critical vulnerabilities have been identified in Adobe Flash Player 10.1.102.64 and earlier versions for Windows, Macintosh, Linux, and Solaris. These vulnerabilities could cause the application to crash and could potentially allow an attacker to take control of the affected system.

reference LINKS:

Cisco IntelliShield ID:22576
Adobe Security Update: APSB11-02
Adobe Flash Player Download
Linux Flash Plugin
Red hat Advisory: RHSA-2011:0206-1
CVE-2011-0560

IMPACT ASSESSMENT:

High

Discussion:

The vulnerability exists because of an unspecified error when processing Adobe Flash content. An unauthenticated, remote attacker could exploit the vulnerability by convincing a user to view malicious Flash content, likely by means of a malicious website. If successful, the attacker could execute arbitrary code with the privileges of the user on the targeted system.

To exploit the vulnerability, an attacker must persuade a user to visit a malicious website that hosts crafted Flash content, or provide a crafted .swf file to the user. The attacker would likely use social engineering techniques, such as using e-mail attachments, instant messaging, or other forms of communication, to achieve this objective.

An unauthenticated, remote attacker could exploit this vulnerability to execute arbitrary code on a targeted system.

Solution:

Adobe has released updates via automatic mechanisms or at the following links:

Update Adobe Flash Player 10.2.152.32
Flash Player 10.2
FreeBSD Ports Collection Index

 

Addthis